2011年10月19日
【SkyPDF Driver 追加結合における障害のご連絡】
一部SkyPDF製品におきまして、特定の条件下での操作により、「追加結合」の設定が有効とならない事象が発生致しましたので、本件における当社での調査状況および対策を下記の通りご報告申し上げます。
記
1.対象となる製品とバージョン
SkyPDF Pro/Pro Driver(Ver3.13~4.0.15)
SkyPDF Professional/Standard 2010 (Ver4.0.0~4.0.15)
SkyPDF Server MT 2010(Ver4.0.0~4.0.6)
SkyPDF Terminal Server 2010(Ver4.0.0~4.0.1)
2.現象
対象となる製品とバージョンにおいて、ある条件下におけるPDFファイルの生成操作をおこなうと「追加結合」(※)の設定が有効とならず、「追加結合」処理が実行されない現象が発生。
※「追加結合」とは、次の一連の操作手順と実行結果を意味します。
【障害の再現操作手順】
①コンピュータの[プリンタ(とFAX)]から、[SkyPDF Pro Driver(または本対象となる製品名。以下同様)]を選択し、右クリックメニューで [印刷設定]を選択。
②印刷設定画面の[ページ設定]タブを開き、[同名ファイルが存在した場合の設定]プルダウンメニューで、[既存ファイルの後に追加する]→〔OK〕を選んで、設定を保存し、画面を閉じる。
③既存PDFファイルの後に追加したいMicrosoft Office文書(Wordなど) やInternet Explorerなどのアプリケーションを開く。
④開いたアプリケーションの[印刷]メニューから印刷に使用するプリンタとして、 [SkyPDF
Pro Driver]を選択する。
⑤印刷実行後に「PDFファイルに名前をつけて保存」ウインドウが表示されるので、ファイル名欄に、対象となる既存PDFファイル名を選択し、上書き保存する。
⑥作成したPDFを開くと、既存ファイルの後に対象ページが新規追加されていない。エラーメッセージ等も表示されていない。
【補足】
・スカイコムでは、Windows Vista環境でユーザー運用によるアプリケーション連携により連続自動処理を実施した場合のみ、この障害を確認致しました。
Windows Vista以外のOS環境におけるアプリケーション連携時およびアプリケーション連携を使用しない一般的手動操作では再現の確認報告は受けておりませんが、発生の可能性が残ることを報告致します。
3.原因
PDF作成時の内部処理の流れと致しまして、一時フォルダに一時的にファイルを作成後、最後に指定された保存先に移動していますが、ここで、OS上でファイルの移動削除を頻繁に行っている場合や、OS の起動時のように頻繁にファイルの I/O 要求が発生しているような状況になっている場合、ファイルの移動に失敗していました。
また、このような失敗はOSの仕様によるものであるとMicrosoft社より回答を得ています。
4.影響範囲
上記対象製品・バージョンにおいて追加結合を使用している場合のみです。
Windows Vista環境でユーザー運用によるアプリケーション連携により連続自動処理を実施している場合のみ、この障害を確認致しました。
それ以外の利用に関する再現の確認報告は受けておりませんが、発生の可能性は残ることを報告致します。
5.対応
保存先フォルダへ移動する処理の見直しを実施し、現象が発生しなくなったことを確認致しました。万が一を想定した、リトライ処理の追加、さらに、所定回数リトライ実施してもエラーになる場合はエラーメッセージを表示させる対策を実施しています。
5.対策
<未対策版での一次回避>
・当該の追加結合を使用する場合は、作成したPDFのページ数などに抜けが無いか等の出力結果を確認し、問題がある場合は、再度PDF作成を実施してください。
<対策版のリリース>
・SkyPDF Professional/Standard 2010 におきましては、Ver4.0.16にて改修されております。
アンインストール不要でアップグレード可能(設定は初期設定に戻る)となります。
以下のURLよりダウンロード可能です。
http://www.skycom.jp/download.html
・SkyPDF Pro Driver におきましては、Ver4.0.16にて改修されております。
Ver4.0.0以降であれば、アンインストール不要でアップグレード可能(設定は初期設定に戻る)となります。
・SkyPDF Server MT 2010、SkyPDF Terminal Server 2010 におきましては、次版(2011年10月末リリース予定)にて対応致します。
ご利用のお客様におかれましては、多大なご迷惑おかけいたしますこと、深くお詫び申し上げます。
|